Outage in Clifton & Zorn Avenue area
Incident Report for IgLou Internet Services
Resolved
The outage has been repaired successfully.
Posted 10 months ago. Jan 08, 2019 - 12:20 EST
Identified
We are aware of an outage affecting home and business Internet customers in the Clifton, Zorn Avenue, and Frankfort Avenue areas in Louisville. While the telephone company is aware of the issue, we do not yet have an estimated time of repair.
Posted 10 months ago. Jan 07, 2019 - 15:35 EST
This incident affected: Internet Access Services.