Outage in Germantown area in Louisville
Incident Report for IgLou Internet Services
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 03, 2019 - 14:10 EDT
Update
The outage in the Germantown area has been repaired and service should now be restored.
Posted 3 months ago. Apr 03, 2019 - 12:01 EDT
Identified
We are aware of an outage affecting home and business Internet customers in the Germantown and surrounding area in Louisville. While the telephone company is aware of the issue, we do not yet have an estimated time of repair.
Posted 3 months ago. Apr 02, 2019 - 14:06 EDT
This incident affected: Internet Access Services.