Weather related outages
Incident Report for IgLou Internet Services
Resolved
This incident has been resolved.
Posted 2 months ago. Nov 20, 2018 - 09:45 EST
Update
News channels are now reporting that Louisville's Thursday morning ice storm is considered a top-10 event based on the number of power-outages and downed lines. Internet customers throughout the area are still being impacted with no specific repair ETAs for most customers. We are being advised that times for repair may range between 1 and 5 days depending on the amount and type of damage in any given neighborhood.
Posted 2 months ago. Nov 16, 2018 - 11:15 EST
Monitoring
Individual trouble reports are being accepted, but individual ETA for repairs may vary between 24 and 72 hours if your service is impacted by this weather-related event.
Posted 2 months ago. Nov 15, 2018 - 15:49 EST
Investigating
There are a large number of known outages affecting Internet access customers in the Louisville area due to the icy weather event that occurred early Thursday morning. If your power was recently restored, please keep in mind that other power outages in your area may still be affecting your service.

Internet customers without service are encouraged to power-cycle their modem and ensure that all cables are still connected properly before further troubleshooting.
Posted 2 months ago. Nov 15, 2018 - 15:46 EST
This incident affected: Internet Access Services.