Spectrum & Centurylink connectivity issues
Incident Report for IgLou Internet Services
Resolved
We are no longer receiving reports of connectivity issues. Closing as resolved at this time.
Posted 11 days ago. Oct 10, 2019 - 10:59 EDT
Investigating
We have received multiple reports from Spectrum customers having trouble reaching IgLou's email and hosting servers. We've also seen multiple reports on several network discussion forums that there may be peering problems between Spectrum & Centurylink. If you are experiencing trouble reaching IgLou's services over a Spectrum circuit you may be affected by this issue. We are still gathering information and have not yet received any official confirmation from either Spectrum or Centurylink. If you have any information to share, please contact us at support@iglou.com
Posted 12 days ago. Oct 09, 2019 - 12:24 EDT
This incident affected: Network Connectivity, Server Colocation, and Website & Email Hosting.